1+2+……+10^n - waiting...'s Blog
1+2+……+10^n
-
//题目描述:
-
//传说中数学王子高斯小时候利用规律很快的将1+2+……+100算出来
-
//现在有一个类似的问题,就是要求1+2+……+10^n.
-
//你能很快地算出来么?
-
//
-
//输入:
-
//多个case,每个case只有一个自然数 n (0<=n<=10000)
-
//
-
//输出:
-
//上面那个问题的结果
-
//
-
//样例输入:
-
//1
-
//2
-
//
-
//样例输出:
-
//55
-
//5050
-
-
-
#include "stdafx.h"
-
#include <iostream>
-
using namespace std;
-
-
int main()
-
{
-
int n;
-
void calculate(int n);
-
while (cin >> n)
-
calculate(n);
-
return 0;
-
}
-
-
void calculate(int n)
-
{
-
if (n == 0)
-
{
-
cout << "1" << endl;
-
return;
-
}
-
-
cout << "5";
-
-
int num_0 = n;
-
while (--num_0 > 0)
-
cout << "0";
-
-
cout << "5";
-
-
num_0 = n;
-
while (--num_0 > 0)
-
cout << "0";
-
-
cout << endl;
-
}